USCA Sidecar Forum

For some extra information about navigating the forum you can go to Forum Tips

You need to log in to create posts and topics.

Cannot find this site with Internet Explorer

I have run into a strange problem with this site. I normally use Internet Explorer as my browser. Works fine for anything I do. I tried to log into this site and it cannot find the site. I did a Google search and it comes up. When I click on the link it takes me to another search site that cannot seem to find it. I have typed the URL directly into my ID browser and still cannot find the site.

Now, my IE may have been invaded by some kind of malware that inserts this strange search engine. I need to look into that.

I'm opening this thread using Google Chrome. Works fine.

Have any changes been made to the site that would make it invisible, for lack of a better term, to IE?

UPDATE: I may have figure out what is going on. I put sidecar.com into my IE browser and it worked. I went back and put https://www.sidecar.com into my browser and it took me to that strange search engine. I put https://www.sidecar.com into Google Chrome and it took me to the same strange search engine. It would appear that when you do a search on Google for sidecar.com, it brings up the link to the website, but that link must be https://www.sidecar.com and NOT just sidecar.com. Not sure if this means that the site needs to correct how it is registered on Google.

FOLLOW UP: I just did a Google search on Chrome for sidecar.com. It found the USCRA site and when I clicked on that link, it took me to that same goofy search engine. Looks like Google thinks the site is at http://www.sidecar. com and not at simply sidecar.com.

Thanks,
Rob

I was having the same problem with safari and after going through things with the apple help line I got in with another browser by using a sidecar forum link. Once in I noted the heading was sidecarist.com and my bookmark bar had accessed it with sidecar.com until earlier this week. When I Searched sidecar.com or united sidecar association it also took me to another list which appeared to be advertisements. Updated my bookmark to sidecarist.com and now it opens. See if this works for you.

I found that things worked again if I cleared my "History". If you have Win 10, you can make choices about what to clear and what to keep. I kept my passwords and all that worked fine.

Good Luck!

I've run into the same problem in the last few days using Google Chrome. Tried switching to Internet Explorer and that didn't work. Seemed like clearing history and the internet cache worked. But right back to the same odd search site. Then Ned (Drone) told me try sidecarist.com instead of sidecar.com. Seems to work every time. So far... Hope the trend continues!! I miss this forum when it seems inaccessible....

Attached files

Tom Wells aka Reardan Tom

Sidecarist.com works at the moment but don't count on it. It is used as a test site from time to time and might disappoint you.